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Part I: General

1. Introduction
The Botswana, Namibia, and Mozambique PDE (Population–Development–Environment)
models were developed by the Population Project at the International Institute for Applied
Systems Analysis (IIASA, www.iiasa.ac.at/Research/POP/) in Laxenburg, Austria, as an
easy-to-use model to test a range of policies via simulation of population–development–
environment interactions.

This preliminary user’s manual includes the disclaimer, background information, short model
descriptions, and instructions on how to use the supporting software (Vensim® Model
Reader), how to use the models, and how to run simulations.

2. PDE Model Developers
Warren C. Sanderson and Molly E. Hellmuth developed the Botswana and Namibia PDE
models.

• Molly E. Hellmuth developed all water models in cooperation with Kenneth M. Strzepek
and David N. Yates, with input from Alyssa Holt.

• Warren C. Sanderson and Molly E. Hellmuth developed the economic models.

• Warren C. Sanderson developed the demographic models with significant help from
Kuberin Packirisamy and Annababette Wils.

Annababette Wils developed the Mozambique PDE model.

• She used the input from the demographic models of Botswana and Namibia.

• She also developed the economy and education models for Mozambique.

• Molly E. Hellmuth developed the water model in cooperation with Kenneth M. Strzepek
and David N. Yates.
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3. File Names of the PDE Models
All data input files are necessary to run the PDE simulation models. For instance, the
Mozambique model consists of one model file and two data input files; all three files must be
downloaded. Users can download the model and data input files of the desired model by
downloading the zip file as listed below.

PDE model PDE model file (.vmf) and PDE
model data input file (.vdf)

Download

Botswana Demographic
Model

BotswanaDemographicModel.vmf BotswanaDemographicModel.zip

Botswana Economic
Model

BotswanaEconomicModel.vmf

LABORFORCE1.xls

BotswanaEconomicModel.zip

Botswana
SER Water Resources
Model

BotswanaWaterSER.vmf

BOTSHCPOPDEM.vdf

climBOTSgen900yrly.vdf

BotswanaWaterSER.zip

Gaborone Water Supply
and Demand Model

GaboroneModel.vmf

CSGen900yrly.vdf

GabHCPOPDEM.vdf

GaboroneModel.zip

PDE Mozambique
English version

MozambiqueEnglish.vmf

mozinputenglish.vdf

climate.vdf

MozambiqueEnglish.zip

PDE Mozambique
Portuguese version

MozambiquePortuguese.vmf

mozinputportuguese.vdf

climate.vdf

MozambiquePortuguese.zip

Greater Maputo City
Water Supply and Demand
Model (English version)

MaputoStudy.vmf

MaputoStudy.vdf

MaputoStudy.zip

Namibia Demographic
Model

NamibiaDemographicModel.vmf NamibiaDemographicModel.zip

Namibia Economic Model NamibiaEconomicModel.vmf

NamibiaLaborForce1.xls

NamibiaEconomicModel.zip

Namibia
SER Water Resources
Model

NamibiaWaterSER.vmf

NAMHCPOPDEM.vdf

clim500NAMyrly.vdf

NamibiaWaterSER.zip

Windhoek Water Supply
and Demand Model

WindhoekModel.vmf

namibiaCSclim1000yr.vdf

WindHCPOPDEM.vdf

WindhoekModel.zip
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4. Software
The software required to open and run the PDE models – the Vensim® Model Reader – can
be downloaded free of charge from www.vensim.com. Any questions regarding the Vensim®
Model Reader should be directed to the official Vensim® contact addresses.

For the most up-to-date versions of the PDE models, see www.iiasa.ac.at/Research/POP/pde/.

5. Disclaimer
The PDE models are distributed solely on an “as is” basis. The entire risk as to quality,
appropriateness, and performance is assumed by the user. IIASA does not guarantee, warrant,
or make any representation regarding the use of, or the results of the use of, these models in
terms of correctness, accuracy, or otherwise. The user relies on the models and the results
solely at his/her own risk. IIASA does not assume liability for any direct, indirect, incidental
or consequential, special or exemplary damages, regardless of whether the user has been
advised of the possibility of such damages.

IIASA declines all responsibility for errors or deficiencies in the database or software or in the
documentation, for program maintenance, and for upgrading. IIASA also declines any
responsibility for updating the data and does not assume liability for damage caused by errors
and omissions in the data provided.

The PDE models were developed with Vensim® DSS Software. They can be used with the
Vensim® Model Reader, which can be downloaded free of charge from www.vensim.com.
Users of the Vensim® Model Reader must agree to the Vensim® Software License
conditions. Regarding the Vensim® Model Reader, IIASA does not assume any liability for
any direct, indirect, incidental or consequential, special or exemplary damages, regardless of
whether the user has been advised of the possibility of such damages.

6. Acknowledgments
The IIASA team wishes to express appreciation to the following country coordinators and
collaborators for their helpful input, data support, comments, and energy: Mr. Rebasele
Radibe (Botswana); Mr. Lazarus Hangula and Mr. Ben Fuller (Namibia); Mr. Manual da
Costa Gaspar, Mr. Emídio Sebastião, and Ms. Maimuna Ibraimo (Mozambique); Mr. Kuberin
Packirisamy and Mr. Paul Kibuuka (South Africa); Mr. Hassan Musa Yousif (Cote d’Ivoire);
and Ms. Alyssa Holt, Mr. Kenneth Strzepek, and Mr. David Yates (USA).
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Part II: PDE Model Descriptions

1. The Botswana PDE Model and the Gaborone Water Supply
and Demand Model

1.1. The Demographic Model
The Botswana demographic model was constructed as part of the project to provide
information about what would happen to the population of Botswana, which is severely
affected by HIV/AIDS, under various scenarios. For example, the model allows policy makers
to determine the consequences of alternatives such as a successful program that reduces the
riskiness of sexual behavior or a government program to provide HIV/AIDS medication to
those in need. In these uncertain times, this kind of information can make the difference
between policies that help and policies that do not.

The philosophy behind all our models is that they should be as simple as possible, consistent
with staying close to the data and capturing the major structural features of the phenomenon.

Categories
The population is divided (1) by age (100 ages from 0 through 99+); (2) by sex (female and
male); (3) by education (primary and below, secondary, tertiary); (4) by HIV status (HIV
negative; HIV positive, asymptomatic, and not on medication; HIV positive, asymptomatic,
and on medication; and AIDS, i.e., symptomatic); (5) by number of years since HIV infection
(15 categories from infected this year to infected 14 or more years, for people who are HIV
positive, asymptomatic, and not on medication); (6) by sexual behavior risk group (not at risk,
sometimes at risk); and (7) by onset of sexual activity (for young women and men).

Data on the initial population by age, sex, and education are taken from the 1991 Census of
Botswana. Initial data on HIV prevalence by age for females are derived from the 1993 and
1997 Sentinel Surveillance Surveys after adjustment for geographical representativeness.
There are no prevalence data for men. Before they can be used, the aggregate prevalence rates
have to be adjusted for the relationship between education, fertility, and HIV prevalence and
for the effect of HIV on fertility. Because there are no prevalence rate data on men, their
incidence rates will be determined based on the incidence rates for females. The relationship
between the incidence rates of men and women five years younger than they are is under the
control of the user.

Forecasting the Non-HIV/AIDS Population
There has been a great deal written about population forecasting and we need not repeat it
here. The non-HIV/AIDS population is projected using the standard cohort component
approach. This involves forecasting the total fertility rate by education, life expectancy at
birth by education, and migration rates. The time profile of total fertility rates by education
and the time profile of life expectancy at birth are both under the control of the user. In the
present version of the model, international migration is ignored. The time paths of the total
fertility rates and the life expectancies at birth appear in the programs as lookup functions.
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Forecasting HIV/AIDS Incidence and Prevalence Rates
The most difficult part of the program is the determination of the HIV incidence rates. This is
done by adjusting prevalence rates for two years. In the case of Botswana, these are 1993 and
1997. Given consistent prevalence rates by age at these two dates, it is possible to estimate
incidence rates. With incidence rates and prevalence rates, it is possible to estimate a set of
age-specific prevalence-incidence relationship equations. This process requires a set of
constants that can be specified by the user.

Three constants are required. One specifies the heterogeneity in the riskiness of sexual
behavior. Another represents the manner in which those at risk interact with those not at risk.
The third specifies the reduction in infectibility due to the use of medication. All appear on
the relevant screen.

Forecasting the Number of New Infections
Once the initial prevalence rates and the prevalence-incidence relationships are determined for
each single year of age (for 15 through 49 for women), we can compute age-specific
incidence rates. Multiplying the number of women at risk of becoming infected at each age
with the incidence rate yields the number of newly infected women at each age.

Forecasting the Number with Symptoms and the Number on
Medication
The distribution of durations between infection and symptoms is assumed to be normal with a
mean and standard deviation determined by the user. The mean can change over time in a way
that users can control. The change in the mean duration to the onset of symptoms is also a
lookup function and appears on the relevant screen.

With the onset of symptoms there are two possibilities: either the woman begins receiving
medication or she does not. The user controls the probability that a newly symptomatic
woman begins medication. If the woman begins medication, she is transferred into the status
of being HIV positive, asymptomatic, and on medication. Otherwise she is transferred into the
symptomatic category. In each year, a woman on medication has a probability of remaining
on medication and a probability of becoming symptomatic. This probability is set by the user
and can be found on the appropriate screen. Once a woman enters the symptomatic category,
there is only one exit, death. The probability that a symptomatic woman dies each year is
determined by the user.

Forecasting the Number of Deaths Due to HIV/AIDS
The only deaths due to HIV/AIDS are those of people in the symptomatic (AIDS) category.
Deaths of HIV positive, but asymptomatic women are due to other causes. The number of
deaths is the product of the number of women in the symptomatic (AIDS) category and the
user-specified annual death rate. This death rate is not age specific.

1.2. The Economic Model
The Botswana economic model is what economists call a CGE or computable general
equilibrium model. The term “general equilibrium” is sometimes misunderstood to imply that
the economy being studied is without distortions, rigidities or disequilibria. In fact, “general
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equilibrium” models can be used to investigate all sorts of economies from those that are
heavily distorted to those that come close to the economists’ view of perfect competition.

We have designed the Botswana model to be simple, but yet to incorporate the main features
of the Botswana economy. In the following we discuss the economy’s production structure,
the determination of wages and returns to capital, the structure of demand and savings, the
important role played by the Government of Botswana in the economy, and the determination
of investment flows.

When the model is run in the Vensim® Model Reader, the screens will guide the user.

Production and Output Prices
The economy is aggregated into three sectors: non-agricultural exports (NAE), non-tradables
(NT), and agriculture (including agricultural exports) (AG). The NAE and NT sectors are
represented at the upper-most level by Cobb-Douglas production functions in value-added,
imports, and intermediate goods purchased from the other sectors. Value-added is represented
by a nested constant elasticity of substitution production functions in skilled labor, unskilled
labor, and capital. The agricultural sector is modeled on the basis of livestock herd dynamics
and is made responsive to rainfall.

Non-agricultural exports include diamonds, other mining products, tourism, and
manufacturing exports. The non-tradable sector includes a wide variety of activities from
construction to health care. The agriculture sector includes the output of commercial and non-
commercial farms and includes exports of live animals and meat.

The advantage of the nested constant elasticity of substitution form is that skilled labor and
capital can be made complementary inputs, while the aggregate of the two can be
substitutable for unskilled labor. This is the situation commonly found in developing
countries.

The price and the quantity of NAE output are assumed to be determined exogenously by
international conditions. This is certainly true about diamonds, Botswana’s main export. The
price and the quantity of NT output are both assumed to be determined endogenously. The
price and the quantity of AG output are assumed to be determined exogenously. The price is
determined internationally and the quantity is determined by rainfall and initial herd size
relative to the level desired by the farmers.

Output in the NT sector and input demands are determined using the assumption of profit
maximization. Output in the NAE sector is determined exogenously. Given the output level,
inputs are determined so as to minimize the cost of production.

Determination of Wages and Returns to Capital
The supply of skilled labor is assumed to be exogenous and determined from the Botswana
demographic model. The wage rate of skilled labor is determined so that the demand for labor
at that wage rate is equal to the exogenous supply. The wage rate of unskilled labor is not
assumed to clear the market for unskilled labor, allowing unemployment of unskilled labor to
exist. In the NT sector, skilled and unskilled wage rates are equal to the respective values of
their marginal products.

In Botswana, holding skill level constant, wages in the NAE sector are higher than they are in
the NT sector. This is represented by a constant sectoral wage rate ratio. The model also
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includes a constant ratio of skilled to unskilled wages holding the sector constant. The model
assumes that no skilled laborers work in the AG sector.

In the NT sector, the earnings of each unit of capital are equal to the value of the marginal
product of that capital. In the NAE sector, return to each unit of capital is determined as a
residual, given the price of output, the quantity of output, the prices of the other inputs, the
quantities of the other inputs, and the initial stock of capital.

Structure of Income, Demand, and Savings
In the NAE and NT sectors, incomes are earned by skilled workers, unskilled workers, and
capital. In the AG sector, all income is assumed to be earned by unskilled workers. Income
flows are aggregated across sectors. What remains are the aggregate incomes of skilled
workers, unskilled workers, and capital.

Some income goes to pay taxes. What remains can be used to buy the outputs of the NT
sector, the AG sector, and imports, or it can be saved. The allocations of the three after-tax
earnings to the four possible alternatives are made using three separate extended linear
expenditure systems (ELES).

The Role of the Government
The Government of Botswana plays a number of crucial roles in the economy. It provides
critical services such as education and health care. It invests in infrastructure, and it varies its
level of spending so as to achieve macroeconomic balance. The Government is both a
producer of services and a consumer of them. There is only one NT production function, so
Government-produced services are not distinguished from other NT outputs. The model
distinguishes between Government consumption (including education and health care) and
Government investment. It does not subdivide Government consumption by activity, although
this would be an easy extension to make. When the Government consumes and invests, it
spends money on the outputs of the NT sector and on imports. The proportions spent on NT
output and imports differ depending on whether the Government is consuming or investing.

Government revenues come from two main sources: (1) taxes and royalties on incomes that
would otherwise go to capital, and (2) tariff revenues. Botswana is a member of SACU, the
Southern African Customs Union, which collects all tariff revenue for all of its member
countries and then allocates that revenue back to the member countries. Tariff revenue will
significantly decrease in the future due to Botswana’s international agreements and the EU-
South African Free Trade Agreement. The model distinguishes between the two sources of
income and allows the tariff rate to change over time. In the model tax rates differ by sector,
but do not change over time. The incorporation of time varying tax rates would be an easy
extension.

The Government of Botswana normally runs a budget surplus in order to maintain
macroeconomic balance. Government expenditures are adjusted downward when there is
inflation in the Pula compared to the currencies of Botswana’s main trading partners, and
upward when the reverse is true. In the model, the rate of increase in Government spending
changes each year depending on the previous year’s growth rate of nominal income and on
the previous year’s rate of relative inflation. The sensitivity of changes in Government
spending to the relative rate of inflation is a parameter that may be changed by the user.
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Investment
The fraction of capital income saved and invested depends on the profitability of the NAE and
the NT sectors. Returns experienced in those sectors in 1991 are taken as a benchmark. When
returns exceed the benchmarks, investment rates increase and vice versa. The sensitivity of
investment to profitability is set by the user.

1.3. The Water Models
The water models are designed to provide forecasts of future regional water supply and
demand for Botswana, in order to determine the sustainability of the water supply under
various forecasts of economic, population, and climate changes. There are two models for
Botswana, one for the specific case of Gaborone and one for the Socio-Ecological Region
level.1

Figure 1 shows a schematic of the water model. The water model breaks the region of interest
down into the pertinent watersheds that contribute water to the surface and groundwater
supply. The water that is available to consumers is the surface water runoff that is captured by
surface infrastructure, or the groundwater recharge that allows sustainable abstraction. This
water is then available as supply for the end users, or demand centers.

Surface Water
Runoff over the

Watershed

Groundwater
Recharge over

Aquifer

WATER SUPPLY
INFRASTRUCTURE

DEMAND
CENTER

AVAILABLE
SUPPLY

POPULATION,
DEVELOPMENT

ENVIRONMENT

Climate Change

STRESS??

Figure 1. Water model schematic.

1 For a complete description of the methodology of the water model, see “Methodological Framework of the
Southern African Integrated (SAINT) Model of Water Supply and Demand” by Molly E. Hellmuth, Kenneth M.
Strzepek, and David N. Yates (2000). Draft available from the author: hellmuth@iiasa.ac.at.
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The SER Water Supply and Demand Model
The Socio-Ecological Regions (SERs) are shown in Figure 2.

Figure 2. Socio-Ecological Regions.

There are five major hydrologic basins that were aggregated into macro basins from sub-basin
maps (ALCOM, FAO) and delimited for analysis: Upper Zambezi, Okavango Delta, Orange
River, Southern Interior, and the Limpopo. These basins are shown in Figure 3.

200 0 200 400 Miles

Watersheds
[LimpBW]
[LimpSA]
[OkAn]
[OkBw]
[OkNa]
[OrBw]
[SIBW]
[UZambAN]
[UZambBW]
[UZambNA]
[UZambZA]

Botswana N

EW

S

Figure 3. Modeled water basins.

The modeled watershed sub-basins do not always directly correlate to the SERs. One could
attribute the Okavango Basin to SER1, and the Orange, Southern Interior, and Upper Zambezi
Basins to SER3. The Limpopo Basin and SER2 correspond directly. The amount of available
water for each of these basins changes, depending on the scenario. The water is distributed
amongst the SERs according to the percentage of the basin area they cover, the capacity of the
infrastructure to store or transfer water to consumers, and the sustainable groundwater
recharge rates. There is a macro reservoir for each SER center, which represents the total
storage available for the SER. Similarly, the sustainable level of recharge which can be
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extracted for human consumption was modeled for each basin and then summed over the SER
it supplies.

The connection of the water models to the population and development models occurs on both
the water supply and demand sides. On the water demand side, population size, GDP per
capita, and sectoral GDP drive the water use of the domestic, industrial, institutional, mining,
energy, agricultural and livestock consumers. Domestic water use changes as a result of
incomes (GDP per capita), urbanization, and population size. Industrial, Energy and
Institutional water demands are linearly related to the total industrial and commercial output,
which changes with each population scenario. The water demands for irrigation are unequally
distributed throughout the year, depending on the growing cycle of crops. On average, 14,000
cubic meters per hectare are used every year, which means that irrigation technology is rather
inefficient. The growth of water use in mining is driven by changes in the exports economic
sector. Livestock water use changes as a result of changes in livestock production, which may
grow or decline depending on the economic demand.

Scenario Options

The following variables may be changed or turned on (=1) or off (=0) depending on the
choice of the modeler:

1. Time Scale: The model may be run at the monthly or yearly time scale, which allows the
user to consider seasonal effects of water supply.

2. Start Time: Changing this value allows the user to consider scenario choices under
different climate conditions. Since we do not know what future precipitation or
temperature will be, the user may pick a number between 0 and 970 to choose a future
climate.2

3. Climate Change: This allows the user to run the model with future climate change
assumptions incorporated. The Hadley Center Global Circulation Model produced
predictions in future variations of precipitation and temperature by month. Set to 1 if you
would like to consider the effects of climate change.

4. Groundwater Scenario: Turn on by setting equal to 1. Groundwater resources can be
expanded to meet some of the growing pressure on the surface water supply.3

5. Demand Side: Set this value to 1 if you would like to consider conservation measures in
water consumption. This scenario reduces future industrial water consumption by
changing the efficiency of water consumption over time. It reduces domestic water
consumption by assuming zero growth in low and high income per capita domestic water
use.

6. Percent Efficient: To consider the effects of higher water use efficiency in industrial use,
please modify the Efficiency variable to incorporate the percentage of reduction in water
use. This will gradually become more efficient as we move from 2002 to 2021.

2 The start time is a random number to start the model with a different climate. For instance, if you type in 12, it
will take the first month of precipitation (i.e., January, "year 12"). If you type in 780, it will take the first month
of precipitation that is found in data series 780. Since we do not know what the future climate will be, auto- and
cross-correlated 1000-year monthly data series of precipitation, temperature and vapor pressure were created.
3 This option must be used with caution and knowledge of realistic future sustainable groundwater abstractions.
Figures of expected future groundwater extractions for each SER are turned on if the groundwater scenario is
used.
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Case Study: The Gaborone Water Supply and Demand Model
As Gaborone continues to grow as a result of urbanization, so will the city’s water needs. The
infrastructure of the existing water supply system as well as possible new sources were
modeled. Figure 4 shows the existing infrastructure for Gaborone.

Figure 4. Existing infrastructure for Gaborone.

Greater Gaborone’s water supply currently comes from four main reservoirs: the Gaborone
Reservoir, the Bokaa Reservoir, the Nnywane Reservoir, and the Molatedi Reservoir (South
Africa). Additionally, the North South Carrier (NSC), which began operating in 1999,
provides water from the Letsibogo Dam. The Palla Road wellfield groundwater supplies for
the greater Gaborone region were also modeled. Four main demand nodes were included in
the model: Greater Gaborone,4 Palapye,5 Mahalapye,6 and Selebi-Phikwe.7 It was necessary to
incorporate these additional centers as they share water supplies with Gaborone through the
NSC. Gaborone was given priority for the water supply from the NSC.

Additionally, there are rule curves that are applied to each of these sources to allow for
efficient use of storage. The demand was allocated in the following manner:

1. Water demands are calculated at each node. The Gaborone demand is at the top of the
hierarchy.

2. Water is transferred to the Gaborone Dam from the Molatedi Dam following the
agreement made between Botswana and South Africa: If the Molatedi Dam is more than
25% full, 7.2 million cubic meters per year may be transferred, otherwise Botswana
receives only half of this entitlement.

3. Water is transferred from the Bokaa and Nnywane8 Dams to Gaborone (if necessary).

4 Includes Gaborone, Lobatse, Tlokweng, Mogoditshane, Mochudi, Ramotswa, Metsemetlhabe, Gabane, Oodi,
Modipane, Packlani, Mokolodi, Otse, and Mogobane.
5 Includes Palapye and Morupule.
6 Includes Mahalapye, Kalamare, and Shoshong.
7 Includes Selebi-Phikwe and Mmadinare. They currently consume water from the Shashe Dam and are expected
to be connected to the NSC to relieve pressure on the Shashe Dam which also feeds Francistown’s demands.
8 Nnywane storage was transferred into Gaborone Dam to simplify the modeling process.
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4. Gaborone demands are first met by the sustainable amount of groundwater which is
available from recharge, then by surface supplies.

5. If the Gaborone Dam is less than 50% capacity, water is transferred from the north via the
NSC.

6. Water is transferred from the NSC to meet the demands in Palapye and Mahalapye.

The water demands that are modeled for each of the above demand nodes are Domestic,
Industrial, Institutional and Energy. The population, which is broken into urban and rural
water users drive the Domestic demands. The per capita water use rate for these two
categories is allowed to grow as per capita income grows, until they eventually reach a
maximum water use saturation level. Industrial, Institutional and Energy consumption are
driven by changes in annual GDP in the non-tradables economic sector (described in the
Economic Model Description). This is assumed to be a linear relationship.

Scenario Options

The following variables may be changed or turned on (=1) or off (=0) depending on the
choice of the modeler:

1. Time Scale: The model may be run at the monthly or yearly time scale, which allows the
user to consider seasonal effects of water supply.

2. Start Time: Changing this value allows the user to consider scenario choices under
different climate conditions. Since we do not know what future precipitation or
temperature will be, the user may pick a number between 0 and 970 to choose a future
climate.

3. Climate Change: This allows the user to run the model with future climate change
assumptions incorporated. The Hadley Center Global Circulation Model produced
predictions in future variations of precipitation and temperature by month. Set to 1 if you
would like to consider the effects of climate change.

4. Demand Side: Set this value to 1 if you would like to consider conservation measures in
water consumption. This scenario reduces future industrial water consumption by
changing the efficiency of water consumption over time. It reduces domestic water
consumption by assuming zero growth in low and high income per capita domestic water
use.

5. Percent Efficient: To consider the effects of higher water use efficiency in industrial use,
please modify the Efficiency variable to incorporate the percentage of reduction in water
use. This will gradually become more efficient as we move from 2002 to 2021.

In addition, experienced users may wish to change other variables, such as initial storage
capacities or water losses. The user can change the dates that the satellite cities of Palapye and
Mahalapye are connected to the NSC supply.
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2. The Namibia PDE Model and the Windhoek Water Supply and
Demand Model

2.1. The Demographic Model
The Namibia demographic model was constructed as part of the project to provide
information about what would happen to the population of Namibia, which is severely
affected by HIV/AIDS, under various scenarios. For example, the model allows policy makers
to determine the consequences of alternatives such as a successful program that reduces the
riskiness of sexual behavior or a government program to provide HIV/AIDS medication to
those in need. In these uncertain times, this kind of information can make the difference
between policies that help and policies that do not.

The philosophy behind all our models is that they should be as simple as possible, consistent
with staying close to the data and capturing the major structural features of the phenomenon.

Categories
The population is divided (1) by age (100 ages from 0 through 99+); (2) by sex (female and
male); (3) by education (primary and below, secondary, tertiary); (4) by HIV status (HIV
negative; HIV positive, asymptomatic, and not on medication; HIV positive, asymptomatic,
and on medication; and AIDS, i.e., symptomatic); (5) by number of years since HIV infection
(15 categories from infected this year to infected 14 or more years, for people who are HIV
positive, asymptomatic, and not on medication); (6) by sexual behavior risk group (not at risk,
sometimes at risk); and (7) by onset of sexual activity (for young women and men).

Data on the initial population by age, sex, and education are taken from the 1991 Census of
Namibia. Initial data on HIV prevalence by age for females are derived from the 1994 and
1998 Sentinel Surveillance Surveys after adjustment for geographical representativeness.
There are no prevalence data for men. Before they can be used, the aggregate prevalence rates
have to be adjusted for the relationship between education, fertility, and HIV prevalence and
for the effect of HIV on fertility. Because there are no prevalence rate data on men, their
incidence rates will be determined based on the incidence rates for females. The relationship
between the incidence rates of men and women five years younger than they are is under the
control of the user.

Forecasting the Non-HIV/AIDS Population
There has been a great deal written about population forecasting and we need not repeat it
here. The non-HIV/AIDS population is projected using the standard cohort component
approach. This involves forecasting the total fertility rate by education, life expectancy at
birth by education, and migration rates. The time profile of total fertility rates by education
and the time profile of life expectancy at birth are both under the control of the user. In the
present version of the model, international migration is ignored. The time paths of the total
fertility rates and the life expectancies at birth appear in the programs as lookup functions.

Forecasting HIV/AIDS Incidence and Prevalence Rates
The most difficult part of the program is the determination of the HIV incidence rates. This is
done by adjusting prevalence rates for two years. In the case of Namibia, these are 1994 and
1998. Given consistent prevalence rates by age at these two dates, it is possible to estimate
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incidence rates. With incidence rates and prevalence rates, it is possible to estimate a set of
age-specific prevalence-incidence relationship equations. This process requires a set of
constants that can be specified by the user.

Three constants are required. One specifies the heterogeneity in the riskiness of sexual
behavior. Another represents the manner in which those at risk interact with those not at risk.
The third specifies the reduction in infectibility due to the use of medication. All appear on
the relevant screen.

Forecasting the Number of New Infections
Once the initial prevalence rates and the prevalence-incidence relationships are determined for
each single year of age (for 15 through 49 for women), we can compute age-specific
incidence rates. Multiplying the number of women at risk of becoming infected at each age
with the incidence rate yields the number of newly infected women at each age.

Forecasting the Number with Symptoms and the Number on
Medication
The distribution of durations between infection and symptoms is assumed to be normal with a
mean and standard deviation determined by the user. The mean can change over time in a way
that users can control. The change in the mean duration to the onset of symptoms is also a
lookup function and appears on the relevant screen.

With the onset of symptoms there are two possibilities: either the woman begins receiving
medication or she does not. The user controls the probability that a newly symptomatic
woman begins medication. If the woman begins medication, she is transferred into the status
of being HIV positive, asymptomatic, and on medication. Otherwise she is transferred into the
symptomatic category. In each year, a woman on medication has a probability of remaining
on medication and a probability of becoming symptomatic. This probability is set by the user
and can be found on the appropriate screen. Once a woman enters the symptomatic category,
there is only one exit, death. The probability that a symptomatic woman dies each year is
determined by the user.

Forecasting the Number of Deaths Due to HIV/AIDS
The only deaths due to HIV/AIDS are those of people in the symptomatic (AIDS) category.
Deaths of HIV positive, but asymptomatic women are due to other causes. The number of
deaths is the product of the number of women in the symptomatic (AIDS) category and the
user-specified annual death rate. This death rate is not age specific.

2.2. The Economic Model
The Namibia economic model is what economists call a CGE or computable general
equilibrium model. The term “general equilibrium” is sometimes misunderstood to imply that
the economy being studied is without distortions, rigidities or disequilibria. In fact, “general
equilibrium” models can be used to investigate all sorts of economies from those that are
heavily distorted to those that come close to the economists’ view of perfect competition.

We have designed the Namibia model to be simple, but yet to incorporate the main features of
the Namibia economy. In the following we discuss the economy’s production structure, the
determination of wages and returns to capital, the structure of demand and savings, the
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important role played by the Government of Namibia in the economy, and the determination
of investment flows.

When the model is run in the Vensim® Model Reader, the screens will guide the user.

Production and Output Prices
The economy is aggregated into three sectors: non-agricultural exports (NAE), non-tradables
(NT), and agriculture and agriculture-based manufacturing (AG). The NAE and NT sectors
are represented at the upper-most level by Cobb-Douglas production functions in value-
added, imports, and intermediate goods purchased from the other sectors. Value-added is
represented by a nested constant elasticity of substitution production functions in skilled
labor, unskilled labor, and capital. The agricultural sector, AG, is modeled using a Cobb-
Douglas production function with inputs of skilled labor, unskilled labor, capital, imports, and
intermediate goods purchased from the NT and the AG sectors.

Non-agricultural exports include diamonds, other mining products, tourism, and
manufacturing exports. The non-tradable sector includes a wide variety of activities from
construction to health care. The agriculture sector includes the output of commercial and non-
commercial farms, fisheries, and all manufacturing based primarily on agricultural inputs.

The advantage of the nested constant elasticity of substitution form is that skilled labor and
capital can be made complementary inputs, while the aggregate of the two can be
substitutable for unskilled labor. This is the situation commonly found in developing
countries.

The price and the quantity of NAE output are assumed to be determined exogenously by
international conditions. This is certainly true about diamonds, Namibia’s main export. The
price and the quantity of NT output are both assumed to be determined endogenously. The
price of AG output is assumed to be determined exogenously, while the quantity is
endogenous. AG exports are the difference between AG production and domestic AG
consumption.

Output and input demands in the NT and AG sectors are determined using the assumption of
profit maximization. Output in the NAE sector is determined exogenously. Given the output
level, inputs are determined so as to minimize the cost of production.

Determination of Wages and Returns to Capital
The supply of skilled labor is assumed to be exogenous and determined from the Namibia
demographic model. The wage rate of skilled labor is determined so that the demand for labor
at that wage rate is equal to the exogenous supply. The wage rate of unskilled labor is not
assumed to clear the market for unskilled labor, allowing unemployment of unskilled labor to
exist. In the NT sector, skilled and unskilled wage rates are equal to the respective values of
their marginal products.

In Namibia, holding skill level constant, wages in the NAE sector are assumed to be the same
as in the NT sector. The user can change this assumption and specify a constant sectoral wage
rate ratio. The model also includes a constant ratio of skilled to unskilled wages in the NAE
and NT sectors. The wage rate of skilled workers in the AG sector (mainly for people in
agriculture-based manufacturing) are assumed to be the same as those in the NAE and NT
sectors. Unskilled wage rates, however, are assumed to be different. The ratio of the unskilled
wage rate in AG to those in the NAE and NT sectors is set by the user.
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In the NT and AG sectors, the earnings of each unit of capital are equal to the value of the
marginal product of that capital. In the NAE sector, the return to each unit of capital is
determined as a residual, given the price of output, the quantity of output, the prices of the
other inputs, the quantities of the other inputs, and the initial stock of capital.

Structure of Income, Demand, and Savings
In all three sectors, incomes are earned by skilled workers, unskilled workers, and capital.
Income flows are aggregated across sectors. What remains are the aggregate incomes of
skilled workers, unskilled workers, and capital.

Some income goes to pay taxes. What remains can be used to buy the outputs of the NT
sector, the AG sector, and imports, or it can be saved. The allocations of the three after-tax
earnings to the four possible alternatives are made using three separate extended linear
expenditure systems (ELES).

The Role of the Government
The Government of Namibia plays a number of crucial roles in the economy. It provides
critical services such as education and health care. It invests in infrastructure, and it varies its
level of spending so as to achieve macroeconomic balance. The Government is both a
producer of services and a consumer of them. There is only one NT production function, so
Government-produced services are not distinguished from other NT outputs. The model
distinguishes between Government consumption (including education and health care) and
Government investment. It does not subdivide Government consumption by activity, although
this would be an easy extension to make. When the Government consumes and invests, it
spends money on the outputs of the NT sector and on imports. The proportions spent on NT
outputs and imports is different for Government consumption and investment.

Government revenues come from two main sources: (1) taxes and royalties, and (2) tariff
revenues. Namibia is a member of SACU, the Southern African Customs Union, which
collects all tariff revenue for all of its member countries and then allocates that revenue back
to the member countries. Tariff revenue will significantly decrease in the future due to
Namibia’s international agreements and the EU-South African Free Trade Agreement. The
model distinguishes between the two sources of income and allows the tariff rate to change
over time. In the model tax rates can differ by sector, but do not change over time. The
incorporation of time varying tax rates would be an easy extension. In this version, the model
uses the same tax rate of value-added in all three sectors.

Namibia has committed itself to a policy of one-to-one conversion between the Namibian
dollar and the South African rand. Therefore, the Government of Namibia cannot let the rate
of inflation in Namibia differ significantly from the rate of inflation in South Africa. The
Government of Namibia normally runs a budget deficit. It faces two constraints on how large
a deficit it can run. First, it cannot run such a large deficit that it generates inflation relative to
South Africa. Second, it cannot continually run deficits that endanger the ability of the
country to repay its foreign debt. Our model takes these two constraints into account. In the
model, the rate of increase in Government spending changes each year depending on the
previous year’s growth rate of nominal income, on the previous year’s rate of relative
inflation, and on the last year’s ratio of the deficit to nominal gross domestic product. The
sensitivities of changes in Government spending to the relative rate of inflation and to the
relative size of the deficit are parameters that may be changed by the user.
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Investment
The fraction of capital income saved and invested depends on the profitability of the NAE and
the NT sectors. Returns experienced in those sectors in 1991 are taken as a benchmark. When
returns exceed the benchmarks, investment rates increase and vice versa. The sensitivity of
investment to profitability is set by the user.

2.3. The Water Models
The water models are designed to provide forecasts of future regional water supply and
demand for Namibia, in order to determine the sustainability of the water supply under
various forecasts of economic, population, and climate changes. There are two models for
Namibia, one for the specific case of Windhoek and one for the Socio-Ecological Region
level.9

Figure 5 shows a schematic of the water model. The water model breaks the region of interest
down into the pertinent watersheds that contribute water to the surface and groundwater
supply. The water that is available to consumers is the surface water runoff that is captured by
surface infrastructure, or the groundwater recharge that allows sustainable abstraction. This
water is then available as supply for the end users, or demand centers.
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Figure 5. Water model schematic.

9 For a complete description of the methodology of the water model, see “Methodological Framework of the
Southern African Integrated (SAINT) Model of Water Supply and Demand” by Molly E. Hellmuth, Kenneth M.
Strzepek, and David N. Yates (2000). Draft available from the author: hellmuth@iiasa.ac.at.
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The SER Water Supply and Demand Model
The Socio-Ecological Regions (SERs) are shown in Figure 6.

Figure 6. Socio-Ecological Regions.

There are 17 major hydrologic basins that were aggregated into macro basins from sub-basin
maps (ALCOM, FAO) and delimited for analysis. These basins are shown in Figure 7.
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Figure 7. Modeled water basins.

Water from these basins is distributed to demand nodes by use of information about surface
water supply infrastructure and groundwater recharge rates. There is a macro reservoir for
each SER center, which represents the total storage available for the SER.

Similarly, the sustainable level of recharge which can be extracted for human consumption
was modeled for each basin and then summed over the SER it supplies.

The connection of the water models to the population and development models occurs on both
the water supply and demand sides. On the water demand side, population size, GDP per
capita, and sectoral GDP drive the water use of the domestic, industrial, institutional, mining,
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energy, agricultural and livestock consumers. Domestic water use changes as a result of
incomes (GDP per capita), urbanization, and population size. Industrial, Energy and
Institutional water demands are linearly related to the total industrial and commercial output,
which changes with each population scenario. The water demands for irrigation are unequally
distributed throughout the year, depending on the growing cycle of crops. On average, 15,000
cubic meters per hectare are used every year, which means that irrigation technology is rather
inefficient. The growth of water use in mining is driven by changes in the exports economic
sector. Livestock water use changes as a result of changes in livestock production, which may
grow or decline depending on the economic demand.

Scenario Options

The following scenario options can be run:

1. Time Scale: The model may be run at the monthly or yearly time scale, which allows the
user to consider seasonal effects of water supply.

2. Start Time: Changing this value allows the user to consider scenario choices under
different climate conditions. Since we do not know what future precipitation or
temperature will be, the user may pick a number between 0 and 970 to choose a future
climate.10

3. Climate Change: This allows the user to run the model with future climate change
assumptions incorporated. The Hadley Center Global Circulation Model produced
predictions in future variations of precipitation and temperature by month. Set to 1 if you
would like to consider the effects of climate change.

4. Demand Side: Set this value to 1 if you would like to consider conservation measures in
water consumption. This scenario reduces future industrial water consumption by
changing the efficiency of water consumption over time. It reduces domestic water
consumption by assuming zero growth in low and high income per capita domestic water
use.

5. Percent Efficient: To consider the effects of higher water use efficiency in industrial use,
please modify the Efficiency variable to incorporate the percentage of reduction in water
use. This will gradually become more efficient as we move from 2002 to 2021.

Case Study: The Windhoek Water Supply and Demand Model
As Windhoek continues to grow as a result of urbanization, so will the city’s water needs. The
infrastructure of the existing water supply system as well as possible new sources were
modeled. Figure 8 shows the existing infrastructure for Windhoek.

Windhoek currently gets its water supply from the following surface sources: Omatako, Von
Bach, and Swakoppoort Dams. Current and future groundwater supplies include the
Windhoek, Grootfontein, Goblentz and Tsumeb aquifers. The Gammams reclamation works
recycles a portion of Windhoek’s wastewater and was also included.

10 The start time is a random number to start the model with a different climate. For instance, if you type in 12, it
will take the first month of precipitation (i.e., January, "year 12"). If you type in 780, it will take the first month
of precipitation that is found in data series 780. Since we do not know what the future climate will be, auto- and
cross-correlated 1000-year monthly data series of precipitation, temperature and vapor pressure were created.
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Figure 8. Existing infrastructure for Windhoek.

The groundwater sources in the north are not yet connected as a supply source to Windhoek
and are subject to local demands. Von Bach Dam will receive water directly from a water
transfer canal from the northern groundwater sources. These additional northern groundwater
sources were not explicitly modeled; however, the user can make assumptions of how much
water can be sustainably transferred to Windhoek. The current estimate is 3 million cubic
meters per year (MCM/a) (personal communication, Martin Harris, NAMWater).

Von Bach Dam is the main driver of the surface supply system for Windhoek because it has
the best storage characteristics. Storage characteristics are important because evaporation is
the biggest consumer of the water supply. The operating rules for the three dam systems and
the groundwater transfer to Windhoek were adapted from CAWMP Interim Phase (Volume 1
– Systems Analysis):

1. Transfer water from the Omatako Dam to the Von Bach Dam at a maximum transfer rate
of 30 MCM/a, until the Omatako Dam reaches dead storage level.

2. Transfer water from the Swakoppoort Dam to the Von Bach Dam at a maximum transfer
rate of 4 MCM/a, until the Swakoppoort Dam reaches a minimum storage level of 6.60
MCM/a. The transfer capacity will increase to 10 MCM/a in 2003. Swakoppoort Dam
also supplies Karibib with water.

3. Compute Windhoek’s total water demands. The total demand supplied by the Von Bach
Dam will be reduced by supplies from the Windhoek aquifer and the Gammaman
reclamation plant. Starting in June 2001, the recycled water will have a capacity of 5
MCM/a; the capacity will be linearly increased to 7.5 MCM/a by 2011. Groundwater is
taken at an assumed sustainable rate of 2 MCM/a, although this varies with the monthly
recharge rate.

4. Northern groundwater sources can be connected as scenarios. Current estimates place the
sustainable amount of groundwater that can be transferred from Grootfontien at 3 MCM/a.
The other new groundwater sources are not specifically modeled. The Grootfontein node
is already connected (transfer capacity 2.4 cubic meters per second). This water is subject
to high losses and will be transferred to avoid projected water shortages.

5. Finally, a scenario can be run where water is abstracted from the Kavango River (1.62
cubic meters per second).
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The water demands that are modeled for the Windhoek Municipality are Domestic, Industrial,
Institutional and Energy. The Domestic demands are driven by Windhoek Population, which
is broken into High and Low Income water users. The water use rates for these two categories
are allowed to grow as per capita income grows, but will eventually reach a maximum water
use saturation level. Industrial, Institutional and Energy consumption is driven by changes in
annual GDP in the non-tradables economic sector (described in the Economic Model
Description). This is a linear relationship.

Scenario Options
The following variables may be changed or turned on (=1) or off (=0) depending on the
choice of the modeler:

1. Time Scale: The model may be run at the monthly or yearly time scale, which allows the
user to consider seasonal effects of water supply.

2. Start Time: Changing this value allows the user to consider scenario choices under
different climate conditions. Since we do not know what future precipitation or
temperature will be, the user may pick a number between 0 and 970 to choose a future
climate.

3. Climate Change: This allows the user to run the model with future climate change
assumptions incorporated. The Hadley Center Global Circulation Model produced
predictions in future variations of precipitation and temperature by month. Set to 1 if you
would like to consider the effects of climate change.

4. GW North On: Set this to 1 if you would like to allow Windhoek to receive additional
water supplies from the northern groundwater sources.

5. Maximum Northern Groundwater Transfer: Change this value to allow northern
groundwater sources to be transferred to Windhoek.

6. Banking On: Change this value to 1 if you would like to consider the effects of water
banking. This means that water is transferred to the Windhoek aquifer instead of into the
Von Bach Dam, in order to decrease evaporative losses. For this scenario, runoff into the
Von Bach Dam is diverted into the Windhoek aquifer at a loss of 25%, if space permits.
The pumping capacity is assumed to be 20 MCM/a. The total Windhoek aquifer capacity
is 25 MCM/a.

7. Okavango On: Set this value to 1 if you would like to consider the transfer of water from
the Kavango River to Windhoek.

8. Demand Side: Set this value to 1 if you would like to consider conservation measures in
water consumption. This scenario reduces future industrial water consumption by
changing the efficiency of water consumption over time. It reduces domestic water
consumption by assuming zero growth in low and high income per capita domestic water
use.

9. Percent Efficient: To consider the effects of higher water use efficiency in industrial use,
please modify the Efficiency variable to incorporate the percentage of reduction in water
use. This will gradually become more efficient as we move from 2002 to 2021.

In addition, experienced users may wish to change other variables, such as initial storage
capacities or water losses.
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3. The Mozambique PDE Model
The Mozambique population–development–environment (PDE) model consists of five
sectoral models which are incorporated into the integrated Mozambique PDE model. The sub-
models are explained separately. They consist of (1) HIV/AIDS model; (2) education model;
(3) labor force model; (4) economy model; and (5) water model.

3.1. The Population and HIV/AIDS Model
The population is projected with a cohort component model, the basic demographic tool for
projection. It includes single-year age and gender, and age- and gender-specific rates of
fertility, mortality, and migration. What sets this model apart is that it includes the
epidemiological dynamics of HIV/AIDS.

HIV is an infectious disease, which means there is a relationship between prevalence,
incidence, and susceptible population. The more people are infected, the more the disease
spreads to the healthy people, so in turn, the more are infected. How quickly new people are
infected depends on the relationship between prevalence and incidence, which is determined
by biology and behavior.

If an infected person is healed or dies right away, the prevalence never has a chance to build
up and cause an epidemic. On the other hand, if an infected person lives with the infection for
a long time, prevalence has the opportunity to increase. This is the case with HIV, where the
average time until the outbreak of full-blown AIDS in Africa is estimated to be 7–10 years.
Once a person in Africa has AIDS, the annual mortality is very high, at least 50% annually.

Factors that can limit the spread of the HIV infection are safe sex practices (especially
condom use), treatment of other sexually-transmitted diseases, bottle-feeding infants of HIV-
positive mothers and other interventions. In the future a cheap vaccine might halt the disease.

Figure 9 shows these basic dynamics and the intervention points to limit HIV and AIDS. We
have incorporated the relationship between prevalence and new incidence. If the relationship
is higher, then HIV prevalence rises faster. The model also includes the three intervention
possibilities in the figure. Further, all the dynamics are incorporated into a multi-state age-
and sex-specific population projection model.11 With the model, we can make scenarios,
which take into account how different rates of the diffusion of HIV and the effects of various
policies impact population growth and age structure.
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Figure 9. Flow diagram of HIV and AIDS dynamics.

11 The original version of this model was developed for Botswana by Warren C. Sanderson at the International
Institute for Applied Systems Analysis, Laxenburg, Austria.
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We have incorporated these dynamics into the population projection by dividing the
population into three sub-groups: those without HIV (the NEG population); the HIV-infected
group; and those with full-blown AIDS. Each sub-group is divided by single-year age and
sex, and the HIV group by years since infection. Basically, people move from the NEG to the
HIV population, as given by the new infection rate derived from prevalence. People move
from the HIV to the AIDS population as determined by the years since infection and the
likelihood of progressing to AIDS.�

3.2. Education Model
Basically, the present low levels of educational achievement among Mozambican adults are
the result of a past with low school enrollment rates. In the same way, to project future adult
education – the essential ingredient for development – one needs to start by projecting school
enrollment, including school intake and drop-out rates.

In Mozambique, school entry occurs at many ages, starting at age 5, and ranging up to young
adulthood. Most people who enter school do so between the ages of 5 and 12. Similarly,
school departure occurs throughout the school cycle. In each grade between 6% and 47% of
the students leave (the higher drop-out rates occur at transitions from one school level to the
next). Most, but not all, people who leave school are teenagers. This rather complex situation
is captured in a model with school enrollment by single-year age groups and single grades
from 1–12, as well as separate university enrollment (see Figure 10).

School intake by age

Enrollment by age and grade

Education of adults by grade

Drop-out rate

Teachers

Student/teacher
ratio

Repetition rate

Figure 10. Flow diagram of school enrollment and teacher hiring dynamics
captured in the education model.

A particular concern for the country is whether or not there will be enough teachers,
particularly at the lower primary school level. This concern is more acute in the face of the
HIV/AIDS epidemic. Teachers are expected to have completed the teacher training program,
but in many cases, the shortage of teachers leads to hiring people who have simply completed
a certain minimum of general education.12 The number of teachers is important because
teachers are needed to fill new classrooms; also, the student/teacher ratio is a measure of

12 According to data from the Ministry of Education, there were only 366 graduates from the training schools for
lower primary education in 1998. This is far less than the increase of lower primary school teachers, from 30,513
in 1998 to 33,363 in 1999 (Instituto Nacional de Estatistica, 2000, Mocambique em Numeros 1999, Maputo). In
addition, teachers need to be hired to replace those who leave or die. We estimate that in 1998, about 6,000 new
teachers were hired at the lower primary school level, far fewer than the qualified graduates.
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school quality. A cross-sectional analysis of African countries in 1995 shows that where the
student/teacher ratio is lower, the repetition rate is as well.13 Repetition, which averages 23%
in Mozambique, influences enrollment and greatly increases the inefficiency of school. This
dynamic is also shown in Figure 10.

The HIV/AIDS model gives the absolute size of each sex and age group. Within each group,
the education model calculates the proportions who are in school and not in school, by grade.
The same proportions are applied to the NEG, HIV, and AIDS statuses. Each sex and single-
year age category has a total value of 1. Within that unit, the population is distributed over the
education groups. For example, in 1997, at age 5, 0.951 of the boys and girls are not in school
and 0.049 are in grade 1. At age 6, 0.842 are not in school; 0.112 in grade 1; 0.041 in grade 2;
and 0.005 in post school having achieved first grade.

3.3. Labor Force Model Description
Education does two things to the labor force: it increases the level of skill and therewith the
productivity of workers, and it moves people to cities (because the more educated a person is,
the more likely he or she lives in an urban area). Meanwhile, AIDS takes people out of the
labor force, through death and through home-nursing of AIDS patients. Our model calculates
these effects for the urban and rural labor force.

From the HIV/AIDS and education models, we obtain the total population not in school by
sex, age, and education achieved. Those with full-blown AIDS are not included. The average
labor force participation rates by age, sex and urban or rural residence, from the 1997
Population Census are applied equally, regardless of HIV status or education. This is a
simplification, which was dictated by the data. In reality, possibly, those with higher
education are more likely to participate in the labor force. Only those with university degrees
are assumed to have 100% labor force participation rates. The rates of urbanization are
significantly higher for those with more schooling, as the 1997 Population Census shows.
This difference is included in the model, so, as the labor force becomes more skilled, it
automatically becomes more urban. Moreover, we include an independent, non-education
related urban migration force, so that over time, even within each educational level, larger
proportions live in cities.

Due to HIV/AIDS, a certain number of potential workers are lost, not only those who have the
full-blown disease, but also family members who care for the sick. We assume that care for
the sick is a quarter time job (this assumption can be changed) – for every four AIDS patients,
one additional person is lost from the labor force because of care. After subtracting those who
are caring for the AIDS patients, we have the actual labor force.

While the absolute size of the labor force says something, a true reflection of the economic
potential of workers includes level of skill as well as size. To capture this economic potential,
we calculate the effective urban and rural labor separately from the absolute labor force size.
The effective labor force incorporates relative productivity weights given to each level of
skill. The weights were estimated based on a comparison of incomes in different groups. They
reflect the income distribution of the 1996 Household Survey. We assume income is ranked
by skill – in other words, the unskilled have a lower income than the medium skilled, who
have a lower income than the highly skilled. Figure 11 shows the flow diagram of the labor
force model.

13 Using the database on the UNESCO website: www.unesco.org
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Figure 11. Flow diagram of the labor force model with actual and effective labor force.

3.4. The Economic and Water Models
Figure 12 shows a flow diagram of the economic and water models. Economic production is
divided into urban and rural sectors (equivalent to industry and services versus agriculture).
Urban production is defined by a Cobb-Douglas function,14 which includes effective urban
labor, capital stock, and productivity. Changes in the capital stock are determined by the rate
of domestic investment as a proportion of GDP. Agricultural production is essentially a
function of effective rural labor, productivity, and the effect of soil moisture and rainfall.

Urban production Rural production

Effective urban labor force Effective rural labor force

Capital stock

Capital investment

Gross
national
product

Effect of soil
moisture

Soil moisture
Rainfall

Temperature

Evapotranspiration

Runoff

Skilled
labor
wage

Figure 12. Simplified flow diagram of economic and environmental dynamics
captured in the economic and water models.

14 A standard economic formulation, which is discussed in most textbooks on macro-economics.
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The model also calculates wage for highly skilled labor with a university degree or more, with
a model developed by Kibuuka.15 The basic assumption is that an increase in the demand for
skilled labor is determined by economic growth: when the demand for skilled labor rises,
wages rise. The supply of skilled labor is determined by two factors: the size of the skilled
population and the wage rate. A lower wage rate reduces the supply. The size of the
professional labor force is increased by university graduates and foreign labor and reduced by
migration and deaths, which follow from the HIV/AIDS model.

The water model uses a physically-based hydrologic approach to calculate soil moisture.16

The model includes 25 national and international rainfall catchment areas, which supply water
for the major international rivers running through Mozambique. Not all water is available for
extraction or crop growth. Most of it is lost through evapotranspiration and runoff. The model
calculates the complex non-linear dynamics of these processes, including rainfall,
temperature, vapor pressure, latitude, and soil moisture capacity. Unfortunately, it was not
possible to find data, which would allow us to model in detail the effects of the timing and
quantity of rainfall on agricultural output. The connection of rain and harvest is therefore very
simple: a curve specifying the relative reduction of harvest as a function of rain shortfall in
March.

3.5. Case Study: The Greater Maputo City Water Supply and
Demand Model

As the urban centers in Mozambique expand, so will the demands on the water infrastructure
– namely the water pipes, treatment, and reservoirs. The Greater Maputo City water model
focuses on the Pequenos Limbobos reservoir and the Umbeluzi River basin that feeds it. The
river basin is modeled in the same way as the river basins in the Mozambique model (see
previous section). The reservoir is basically a bathtub; the faucet is runoff from the river basin
and the drain is the extraction of water for irrigation, household, and commercial or industrial
use. The model also includes natural reservoir loss through evapotranspiration and excess
drainage when the reservoir is full (see Figure 13).

The water demands for irrigation, household use and commercial/industrial use are each
formulated separately. The growth in household water demand comes from the product of
three trends: population growth, more people connected to pipes, and consumption increases
for those who are connected to pipes. Each of these three factors is set in user-defined
scenarios. Industrial and commercial water demands are linearly related to the total industrial
and commercial output, and the user defined scenario for output growth rate. By far the
biggest user of the water from Pequenos Limbobos and the Umbeluzi river that feeds it, is
irrigated agriculture. Water demand is unequally distributed throughout the year, dependent
on the growing cycle of crops. On average, 11-15,000 cubic meters per hectare is used every
year, which means that irrigation technology is rather inefficient, and a little under 7000
hectare were irrigated in the Greater Maputo City area. The user can define the water use per
hectare changes over time and area irrigated.

15 Kibuuka, Paul (1997) The Projected Supply and Demand for Professional and Technical Workforce in
Botswana and the Impact of AIDS 1991-2020. Unpublished manuscript, available from the author:
paulk@dbsa.org.
16 Hellmuth, M., K.M. Strzepek, and D.N.Yates (2000) Methodological Framework of the Southern African
Integrated (SAINT) Model of Water Supply and Demand. Draft available from the author: hellmuth@iiasa.ac.at.



27

Umbeluzi basin
soil moisture and

runoff

Pequenos
Limbobos
reservoir

Irrigation
demand

Household
demand

Commercial
and industrial

demand

Hectare irrigated

Monthly water use per hectare

Population of Greater Maputo

Type of water connection

Monthly per capita water use by type
of connection

Commercial and industrial output

Monthly water use per unit of output

Weather

Geographical
characteristics

Swaziland
use Water rationing policy

Figure 13. Flow diagram of the Greater Maputo City water model.

Water demands drain the Pequenos Limbobos reservoir. Once the reservoir is dry, no more
water is available. The model calculates the water deficits, but does not alter the demands. As
water shortages are a possibility, the user can implement two types of policies when the
reservoir reaches dangerously low levels: household water use rationing and cutting off all
irrigation water.
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Part III: PDE Model User’s Guide

1. Download and Installation of the Vensim® Model Reader and
the PDE Models17

Download the PDE model file and the supporting data input file(s) for the model of choice
and the Vensim® Model Reader. For a full list of model data files, see Part I, Section 3.

Install the Vensim® Model Reader by double clicking on the EXE or HXQ file, depending on
your platform.

2. Vensim® Model Reader – Menu, Toolbars and Their Functions
When starting the Vensim® Model Reader for the first time, you will see the following on
your screen (see Figure below). In the following we describe the functions of the Menu and
the Toolbars.18 We will explain how to set up and run simulations based on PDE model
examples.

17 The PDE models were programmed and designed on a Microsoft® platform and have not been used or tested
on other platforms.
18 This manual is based on the Vensim® Model Reader, Version 4.1b (1988-2000. Vensim® Model Reader
Manual and Vensim® DSS Manuals, Ventana® Systems, Inc., USA). Causal Tracing®, Reality Check®,
Vensim® and Ventana® are registered trademarks of Ventana® Systems, Inc. Venapp® and the Ventana® Logo
are trademarks of Ventana® Systems, Inc. Vensim® is covered by United States Patents 5,428,740 and
5,446,652. Patents are pending in the United States and other countries related to portions of the Vensim®
software.



29

2.1. Title Bar, Menu, Main Toolbar, Vertical Toolbar, Bottom Menu

Title Bar

The title bar shows the file name of the model that is open (in our figure above
GaboroneModel.vmf) and the workbench variable (Var:Relative Storage[BASIN]). A
workbench variable is a variable which is “active” and which has been selected by
double clicking on the variable name or by using the variable selection control in the
control panel (Windows>Control Panel>Variable on the Menu).

Menu

Items that are not shown in bold are not available menu commands.

File>Open Model… opens an existing model. The current
model will be closed.

File>Close closes the currently active window.

File>Save As applies only when you have a graph or a table
in the foreground. It saves the contents of the foreground
window as a metafile or a text file.

File>Print prints the contents of the foreground window.

File>Print Options… allows the user to set the printer and
other functions. The same dialogue is available when you
choose File>Print.

File>Exit closes Vensim.

Edit>Copy copies the contents of the selected window to the
clipboard.

Edit>Cut cuts (deletes) the contents of the selected window to
the clipboard.

Edit>Select All selects everything in view.

Edit>Find helps to look for a variable in the model.

Edit>Find Workbench finds the variable which is named in
the title bar.

Edit>Find Again finds another occurrence of the highlighted
variable, if there is more than one.
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Windows>Control Panel (explained later in this chapter).

Windows>Subscript Control (explained later in this chapter).

Windows>Pop Output Forward brings all output windows
(graphs, tables and others) to the foreground.

Windows>Output Window List displays all active output
windows.

Windows>Close All Output closes all output windows except
those which have been locked.

Windows>Error History informs about error messages.

Windows>Selection History lists the variables which have
been selected in the workbench.

Windows>Pop Build Forward brings the model window to the
foreground and puts all output windows in the background.

Windows>Keep Build Behind puts the model window in the
background and keeps it there, even when you click on it.

View>Zoom lets you zoom in or out; the Fit to Screen option keeps the whole screen
visible without scrolling up or down.

Help>Instruction opens the help manual provided by Vensim.

Help>Keyword Search allows you to search by name for help.

Main
Toolbar

Most of commands in the menu can be made using the main toolbar. The name listed
after the button image appears when you move the mouse over the button in the top
toolbar.

Open Model opens an existing model.

Save saves the contents of the foreground window as a metafile or text file.

Print prints the contents of the foreground window.

Copy copies the contents of the foreground window to the clipboard.

Set up a Simulation sets up a simulation. After clicking on the Set icon you
will be able to make changes to the constants or lookup tables.

Name the Simulation to be Made allows you to name a new simulation.

Select a Simulation Name opens a file selection dialogue. You can select an
existing run to overwrite or create a new one.

Run a Simulation starts a simulation or run of the model.

Start a Game starts a gaming simulation.

Run Reality Checks starts a reality check only when the model contains reality
check equations.
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Build Windows–show/circulate brings the model structure (sketch view) to the
foreground and the output windows to the background without closing them.

Output Windows–show/circulate brings the output windows to the foreground.

Control Panel opens the control panel dialogue.

Subscript Control opens the subscript control dialogue.

After clicking on the Set button you will find a few new command icons. These
buttons are needed to make changes to the model constants and lookup tables. They
are the following:

Select an Integration Technique specifies the integration technique that will
be used to run the model. By clicking on the icon you can switch between
Euler and RK4 (fourth order Runge Kutta with an automatic step size
adjustment). This is not available in all models.

List the Datasets to be Used for Data Variables and

Select a Dataset Name opens a file selection dialogue. Choose the
file(s) you want to work with or type directly in the box. If you want
to use more than one file, separate each by a comma.

Change Model Constants opens a dialogue box that contains all of the model
constants, which can be changed directly in the dialogue box. Click Close
when finished.

Change Lookups opens a dialogue box that lists all lookup tables of the
model. Mark the lookup table of choice and click on Modify to open the
graphical lookup editor. Once you have made your changes, click OK.

Stop Simulation Setup stops the simulation setup and will cancel any changes
you might have done!

Vertical Toolbar

The Vensim® Model Reader generates graphic and table outputs that can be pasted
into documents. The necessary toolset can be found on the vertical toolbar. Tools for
structural analysis and dataset analysis are also available on this toolbar (for more
information, see Section 2.2.).

Causes Tree shows a tree-type graph of the causes of a workbench variable.

Uses Tree shows the uses of a variable.

Loops lists the feedback loops of the workbench variable.

Document documents the workbench variable and shows the equations, units
of measure and definitions.

Causes Strip shows the graph of the workbench variable and the graphs of the
causes of the workbench variable. If more simulations are loaded they will be
separated by a line.

Graph shows a graph of the workbench variable with a different colored line
for each loaded simulation (and each subscript element, if multiple subscripts
are selected).
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Table shows the value of the workbench variable at each time in a table.
Same contents as the graph.

Runs Compare lists the changed variables (constants and/or lookups) to
compare the simulation setup.

Bottom Menu

Show the Previous View and Show the Next View (Page Up / Page Down)
navigates through the model.

Choose a View to Look at shows the list of available
views.

Dialogue Toolbar

Delete this window or click on .

Lock this window. When you click on Windows>Close All Outputs in the
menu, the locked output will not be deleted.

Print the contents of this window or File>Print.

Save the contents of this window (as a text or wmf file) or File>Save As.

2.2. Tools to Understand the Structure of a Model

To start a model click on File>Open Model… in the menu or on the button and choose the
model in the selection window. In our example, the Mozambique PDE model
(MozambiqueEnglish.vmf) will open with the following:

Choose the part of the model you want to view by clicking on the box in the flow diagram (in
our example Population and HIV/AIDS) or Choose a View ( ) at
the bottom menu. You can also click on the title on the front page. You will enter the Model
Guide which lists all of the available views. Click on Population and HIV/AIDS.

You will pop into the flow diagram of the Population and HIV/AIDS model (see below). It
shows a simplified structure of the model, the relationships of the variables and the feedbacks
(which are not so visible).
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To better understand the model we use a powerful tool called Causal Tracing®. This helps us
understand why things change. Two different causal relations can be checked: the CAUSES
and the USES of a variable. In the following sections we explain how to do this.

Interpretation of a Causes Tree
Example: We want to understand what causes Births with HIV by sex.

When you move the mouse over a variable, a small text box with yellow background will
appear. The information written in this text box will be (i) the unit for the variable, and/or (ii)
comments. For Births with HIV by sex the message will be people (the unit).

If you double click on this variable it will turn into a workbench variable. It turns into a
workbench variable when it shows up on the title bar. You will see the information

. The name following the
variable name in the square brackets [sex,hivstat] indicates the availability of a subscript. We
will ignore the use of the subscript at the moment and come back to it later (see Part III,
Section 3.2).

Next, click on the Causes Tree button on the vertical toolbar. The following Causes Tree
Diagram dialogue will appear on the screen:

We can see that Births with HIV by sex is caused by %boys (%rapaz) and by births with HIV
(Nascimentos com HIV). Further, we can see that Births with HIV by sex is caused by births
by mothers with HIV (Nascimentos de maes com HIV), births by mothers with AIDS
(Nascimentos de maes com SIDA) and the vertical transmission rate.

Simply explained, this means that the number of children who are born HIV positive,
provided by sex, are calculated in this model by the number of children born with HIV and
the fraction of how many children are boys. Further, the number of children who are born
HIV positive are caused by a combination of three factors: the number of pregnant mothers
who are HIV positive, the number of mothers who have AIDS, and the vertical transmission
rate (the transmission of the HIV virus from the HIV-positive mother to the child).
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Now we would like to understand the causes for the vertical transmission rate. Repeat the
procedure as explained above. Double click on the variable vertical transmission rate in the
Causes Tree Diagram dialogue; the variable will turn into a workbench variable. Then click

on the Causes Tree button:

There are no causes of the vertical transmission rate. In this case it is a constant.

Variable Units and Equations
We would like to understand how these input variables cause HIV-positive births. Or in other
words, what are the equations and units? The cause variables, %boys and Births with HIV, are
not visible in the Population and HIV/AIDS View, so we cannot move the mouse over the
variable to get the text box with the necessary information, as we can for variables available
in View.

Let’s check the units and equations of all the cause variables of Births with HIV in the Causes
Tree Diagram output window. Create a workbench variable for Births with HIV by double

clicking on the variable. Click afterwards on the Document button on the vertical toolbar.
Repeat this procedure for the other variables. The following Document output window will
appear (part of it is shown here).

All of the variables are listed in one Document dialogue. The order of listing is always the
same, according to the rules below:

1) The variable name and an equal sign.
2) The equation.
3) The unit of the variable.
4) The line which separates the variables.
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Based on the list above, the number of children born with HIV per year (Births with HIV,
Unit: people/year) is the sum of the number of children born by mothers who are HIV positive
and by mothers who already have AIDS per year (Births of mothers with HIV and Births of
mothers with AIDS, unit=people/year). This sum is then multiplied by the vertical
transmission rate which is a fraction of the value of 0.3 (i.e., 30 percent of the children born
by mothers with HIV and AIDS are born HIV positive). This leads to the conclusion that the
higher the number of children born by mothers with HIV and AIDS in combination with a
higher vertical transmission rate, the higher the number of births of HIV-positive children.
This is a simplified analysis of what we analyzed in our example, but we have to remember
that we did not check on other causes that might influence this relationship, or if feedback
exist.

Because of the long list in the Document output window, all of the variables will not be
visible at the same time. You can scroll through the list by clicking on the scroll bar to the
right of the output window.

Note: As long the Document output window is active, all of the variables will be listed.

Interpretation of the Uses Tree
We would like to see if the variable Births with HIV by sex manipulates other variables.

Double click on the variable, then click on the Uses Tree button on the vertical toolbar.
You will get the following Uses Tree output window.

The variable influences and affects other variables. In our example we see that the number of
HIV-infected births has many impacts, such as on the HIV-positive population (Populção
total com HIV), the labor force mortality rate including AIDS, and many others. If you wish
to see the equations and units, follow the same procedure as explained in the section Variable
Units and Equations: Click on the variable of interest and then on the Document button.
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Feedback Loops
What are (causal) feedback loops?

A causal loop diagram portrays the information feedback in a system. Feedback is a process
in which an indicator goes through a chain of causal relations to re-affect itself. Feedbacks are
divided into positive and negative feedback loops. On the one hand, a feedback is positive if
an increase in a variable leads to a further increase in the same variable. Positive feedback is
found in systems that produce exponential behavior. On the other hand, a feedback is negative
if an increase in a variable leads to a decrease of the same variable. Negative feedback drives
balancing or stabilizing systems that produce asymptotic or oscillatory behavior.

The Loops tool displays a list of all feedback loops passing through the workbench
variable. The Loops display provides useful information on model interactions. The list starts
with the shortest loop, i.e., the loop which involves the least number of variables. Loops
involving more than 32 intermediate variables will not be listed. If more than 50 loops are
found, you will be asked if you want to see more than the first 50.

Using the variable Births with HIV by sex, let’s see how many feedback loops exist. Turn the
variable into a workbench variable and click on the Loops button. The following question will
appear: There are 112 loops – do you want to see more than the first 50? Click on No. You
will receive the following output window (an extraction). The order is always the same,
starting with the smallest loop in increasing order.

Let’s construct a causal loop diagram of loop number 2 with the length of four variables. The
cause diagram shows Population with HIV by sex and age that is fed by the flow of Births
with HIV by sex. The loop is a positive feedback loop. It shows a closed chain of cause and
effect in which a higher HIV-positive population leads to more births with HIV, and in which
more HIV-positive births lead to a still larger HIV-positive population.
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Output Windows: Save Data, Export Figures, Window Order

The contents of the output windows can be saved by clicking the Save button on the
dialogue toolbar or on the top toolbar, or by clicking File>Save As on the menu. This applies
only when you have a graph or table in the foreground, i.e., when the dialogue is active. The
graphical outputs will be saved as a metafile (placeable wmf format) and the Document,
Loops, Causes Trees, Uses Trees and Tables as text files (txt). The text files can be opened
with any spreadsheet program, so that you can work with the data.

Parts of the dialogue contents can be saved or copy-and-pasted by pressing the mouse button
tightly and moving the mouse over the parts to be copied in the output window. Press Ctrl+C
or File>Copy and paste, for instance, to Word.

Perhaps you have too many windows open in the foreground and want to move them to the
background without deleting or closing them. Go to Windows>Pop Output Forward. All
dialogue boxes will move to the foreground. If you are interested in only one specific
dialogue, it is not necessary to search within the open windows. Go to Windows>Output
Window List and double click on the output you want to look at. The respective window will
appear in the foreground.

2.3. Loading Datasets (Input Data and Scenarios) and Viewing
Graphs of Simulations

You wish to explore the impacts of different scenarios on a certain variable. It might happen
that when you double click on a variable and then on the Graph button, you will receive the
following message:

In this case, close the dialogue by clicking on the button, then click on Windows>Control
Panel>Datasets.

Important: The data input and scenario files (.vdf) must be located in the SAME FOLDER as
the model file (.vmf).
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In the Control Panel window you will see the available datasets on the left (Available - Info…).
There are two ways to move the dataset you want to load: either double click on the dataset,

or single click on the dataset to mark it and click on the button in the middle of the

window. To unload the information use the button. As an example, you can load climate
and mozinputenglish (the model input data files). Click on Close when both file names are
visible in the Loaded - Info… window. Now you can display graphs and tables of results of
interest.

3. Hands-On Examples To Run Simulations

3.1. PDE Mozambique Model, English Version
Let’s continue with the already open model (MozambiqueEnglish.vmf) and stay in the
Population and HIV/AIDS View. In our example we want to learn more about the impact on
the total population size of the introduction of a vaccine in the year 2005 that is accessible to
50% of the population, compared to the non-availability of a vaccine. Now we will need to
change the variables in order to answer this question.

To Change the Variables and to Run a Simulation

Click on the Set up a Simulation button on the top toolbar. This button will now change

into the Stop Simulation Setup button . All variables that can be changed are highlighted
in blue.19

Double click on Percentage of population vaccinated against AIDS to turn the variable into a
workbench variable. A graph lookup dialogue window appears. We see that the loaded base
scenario of the model does not introduce a vaccine, so we do not have to change the lookup
function. Let’s run the first simulation. We’ll name the simulation novaccine, so type
novaccine into the Name the Simulation to be Made box (see image below).

Click on Stop and then on Run a Simulation .20

Let’s run the next simulation, the introduction of a vaccine. Click on the Set button and
double click on the Percentage of population vaccinated against AIDS variable. Now we have

19 The model structure and the input data cannot be changed in Vensim® Model Reader.
20 Should you receive a warning, ignore it and close the window.
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to change the variable. There are two ways to do this: (i) move the line of the graph by using
the drag-and-drop method, or (ii) enter the data in the table on the left. Let’s type in the new
data. In the Input column, we’ll change the year 2004 to 2005; in the Output column we’ll
change the values from 0 to 0.5 (for 50%) for the years 2005 and later. Close the window by
clicking on OK.

Enter the name vaccine2005-50 for this simulation. Run the simulation by clicking on the Run
button.

Note: Every new simulation will be saved as a *.vdf file in the same folder as the model.

Graph Output
We would like to compare the effects of both simulations on the total population size. We will
examine the differences with a graph. Double click on Total Population (workbench variable)
which is located on the right of the same screen. On the vertical toolbar click on the Graph

button and a Graph dialogue including both simulations will appear. You can see that the
results for both runs are the same until 2005. This is the year of the assumed introduction of a
vaccine which is accessible for 50% of the population (vaccine2005-50 simulation). After this
data point, the lines separate with a bigger population size for the vaccine2005-50 scenario
compared to the novaccine scenario.

Graph for Total population

22.67 M

19.40 M

16.12 M

1997 2008.5 2020
Time (year)

Total population : vaccine2005-50 people
Total population : novaccine people

The size of the graph can be changed in the Vensim® Model Reader. Move the mouse over
the right or bottom border until you see the following arrow . Drag the arrow until the
graph is the desired size.
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To retrieve a table output click on the Table icon on the vertical toolbar.

To Change the Range of a Graph
If you would like to have the scale of a graph range from the minimum to the maximum
value, click on the menu Windows>Control Panel>Scaling. Choose Vertical Scaling Raw and
click on Close. Click again on the Graph button on the vertical toolbar. A new graph output
window will appear on the screen.

Other graph layout functions of the Control Panel are:

Scaling>Graph Divisions chooses the number of horizontal and vertical division lines.

Time Axis chooses the range of the X-Axis – the range of the years. Type in the desired range.
If you want to return to the full time range, click Reset to Full Range.

The range can also be changed by pressing “Ctrl” (for the Y-axis) or “Shift” (for the X-axis)
and dragging the mouse over the range to be displayed. Click afterwards on the Graph button
to generate a new graph.

Too Many Simulations are Displayed in the Graph
Let’s say that you have run several simulations. Now you have a graphical output, for
instance, with seven runs (figure below), but you want a figure which displays only two
simulations.

Graph for Total population

22.67 M

19.40 M

16.12 M

1997 2002.8 2008.5 2014.3 2020
Time (year)

Total population : fdbfs people
Total population : fdbf people
Total population : fdbfgbf people
Total population : fdbfgbfg people
Total population : fhrevg people
Total population : vaccine2005-50 people
Total population : novaccine people

Go to Control Panel>Datasets. In the control panel dialogue box on the left you will find all of
the available datasets (Available - Info...). On the right, under Loaded - Info... you will see the
list of the datasets which are currently loaded and which are displayed in the graph. In our
example above, seven datasets are loaded. Mark the datasets to be removed and click on the

button, or double click on the dataset. Close the dialogue and generate a new graph by

clicking on the Graph icon .
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Compare Simulations
To document the changes of the single variables of the simulation, click on the Runs Compare

button on the vertical toolbar. The output shows which simulations are compared (first
row); if constants or lookup functions have been changed (second row); the name of the
variable that has been changed (third row), followed by the numerical information of the
change.

Runs Compare compares only the last two simulations.

Note: We recommend that you document all simulations.

Transfer Graphs, Tables, Runs Compare and Views into a Text
Processing or Spreadsheet Document
You would like to insert the output, for instance, into a Word document. To paste graphs,
tables, runs compare and other output information into a Word document, first mark the
output window.

Then choose between two options in the menu:

− Edit>Save As saves graphs, causes and uses trees, and causes strips either as Windows
metafiles (wmf) or graphics transfer files (gtx). Tables and runs compare can be saved as
text files (txt).

− Edit>Copy copies the contents of the active dialogue to the clipboard. Paste (or Paste
Special) the contents of the clipboard into a Word document. You can also paste the
contents of the clipboard directly into a spreadsheet program such as Excel.

To export the complete view, select Edit>Select All in the menu and follow the steps of the
second option above.

Note: The keyboard shortcuts are: Edit>Copy “Ctrl+C” and Edit>Save As “Ctrl+S”.

Interpreting Results Based on the Causes Strip Graphs
You would like to interpret the results of the two simulations. When we check the equation of
the workbench variable Total Population (click on the Document button) we can see that Total
Population is the sum of Total population without HIV plus Total population with HIV plus
Total population with AIDS. Let’s analyze the results based on the results of these three cause

variables. Click on the Causes Strip button on the vertical toolbar.
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We get an output window which contains four
graphs: Total population (workbench variable) and
the three equation variables.

It shows that the introduction of a vaccine, which is
available for 50% of the population, leads to a
significant reduction of the HIV-positive and
AIDS-infected population over time. Additionally
the non-infected population increases faster in the
vaccine2005-50 simulation compared to the
novaccine simulation.

3.2. The Windhoek Case Study Model

Download the required files into one folder. The model should start with the following view:

To better understand the model structure use the Causal Tracing® tools (for details, see Part
III, Section 2.2).

Understanding the Model
For a descriptive overview of the model, read the model description (see Part II, Section 2.3),
follow the navigation system, and read the model flow diagrams.

We are now interested in the impacts of two different scenarios on the Supply versus Demand
Ratio output variable which represents water stress. This variable is located under Scenarios.
But first we should check the causes and the equation of this variable. Turn the Supply versus
Demand Ratio into a workbench variable by double clicking on it. Next, click on the Causes

Tree button and the Document button . We see that the main causes for the ratio are
the sums of the Surface Supply, Recharge, Emergency Abstraction and the rate of the
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Reclaimed Water to Demands Total. The Document dialogue shows that the workbench
variable is dimensionless (no unit). Compare it to the Causes Tree window – in the equation
we can see how, in mathematical terms, the Supply Versus Demand Ratio is determined. To
analyze other causes, double click in the Causes Tree window on other variables, followed by
a click on the Causes Tree button.

The explanation of the meaning of the output value is found in the Scenario View. Values
between 5 and 2.5 indicate that the system is under stress, while values below 2.5 represent
high stress.

How to Find a Desired Variable
Click on Edit>Find in the menu (short-cut key F5) and a selection dialogue appears. Click on
the desired variable, then OK. The view with the highlighted variable will appear on the
screen. If you would like to know if the variable occurs in other views, click on Edit>Find
again.
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Run Scenarios
We are interested in the effects of conservation measures in water consumption as provided in
the Scenario View compared to no water conservation measures.

Let’s start with the no water conservation simulation. Click on the Set button . All the
changeable variables will be highlighted in blue. Click on Demand Side. We can see that in
the default setup, no conservation measurements are considered. Click on the Stop button

, name the simulation (in our example current) and click on the Run button . Repeat
the procedure for the second simulation which takes water conversation measures into
account, but change the Demand Side scenario option to 1 and name the simulation new1.

For simulations where we changed more than one variable, it might be useful to store the

information of the simulations. Click on the Runs Compare button and save the output
(File>Save As in the menu); the runs compare will be saved as a text file.

View the Results with Graphs and Interpret Them with Causes Strip

To compare both runs with a graph or table, click on the Graph or Table button.
Let’s view the graph.21

21 If you wish to change the scaling, or too many runs are loaded in the graph, see Part III, Section 3.1.
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We can see that Windhoek is confronted periodically with a “water crisis” with increasing
severity up to 2020 in the current simulation (where we did not consider any water
conservation measures).22 But we can see significant improvements in water security in the
scenario new1 (where water conservation measures were considered).

To understand the results in the context of the causes, we can look at the Causes Strip, the
graphical output of the causing factors as seen in the Causes Tree diagram. Click on the

Causes Strip button on the vertical toolbar (make sure that the Supply Versus Demand
Ratio has been turned into a workbench variable). We will get an output window with six
graphs.

In the Recharge and Surface Supply graphs, for instance, we can see the seasonality of
rainfall. The Recharge graph shows the same results for both runs, because we did not change
the climate scenario options. We can see that the Surface Supply from the Von Bach Dam
(indicated by the square brackets following the variable name; a subscript; see below) is
higher and the Total Demand for Windhoek is lower in the new1 scenario, which considers
water conservation measures. You can view the Causes Strip for one of these variables by
double clicking on the variable and then on the Causes Strip button.

!

22 Values between 5 and 2.5 indicate that the system is under stress, while values below 2.5 represent high stress.
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Too Many Runs Viewed in the Graph
To move graphs from the foreground to the background without closing them, click on the

Build Windows button on the main toolbar or click on Windows>Keep Build Behind in the
menu. To bring all of the output windows to the foreground, click on the Output Windows

button; all open windows will move to the foreground. If you continue to click on the
same button, you will circulate through all of the open output windows.

To view a list of all open outputs, click on Windows>Output Window List in the menu. Choose
the output of interest and click OK or double click on it. The output window will move to the
foreground.

You can lock output windows. This makes it much easier to deal with all the output
windows. If you use Windows>Close All Output, all outputs will be closed except the locked
ones.

Subscript Control
We have learned that subscripts are one or more words enclosed in square brackets, which
follow the workbench variable name. We see, for instance, in the Causes Strip figure above
that a few variables have a subscript named Windhoek and one variable Von Bach.

What are subscripts?

Subscripts allow a single variable to represent more than one thing. Almost all variable types
can have subscripts. A variable can have up to eight subscripts separated by commas. The
subscripts do not appear in the sketches (flow diagram view).

To manage the elements of a subscripted variable that are displayed by the Analysis tools, we

have to click on either the Subscript Control button or on Windows>Subscript Control in
the menu. Simple Subscript Control (see left figure below) contains a list of the Subscript
Elements for the applicable Subscript Range.

All selects everything. None removes all selections. Full opens the Elaborate Subscript
Control (see right figure below) for the same Subscript Range.

Available Elements shows all the elements of the Subscript Range.

Selected Subscript Elements are highlighted.

Clicking on a Subscript Element in the Available Elements list highlights it and unhighlights

everything else. The button moves whatever is highlighted in the Available Elements list
to the Selected Elements list.
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We now choose to select all of the Dams. Double click on Dams, then click on the button.
Four Elements will move to Selected Elements. Close Subscript Control and go back to the
sketch. Turn Surface Supply [Von Bach] into a workbench variable and click on the Graph
button. We now have the results of four dams. The current simulation can be viewed below.


